Macro error in UF-003: System.Exception: Could not find Item with UID: "" on Form: 149

Answered

Comments

4 comments

  • Avatar
    erol akgül (Edited )

    I solved the problem. 

    B1UP compiler is converting my colum name as lowercase.

     

    My column name => U_DISMECH

    According to Compiler => U_Dismech

    When I change the column name as a U_DSMECH, the issue was solved..

     

    Normaly, it must understand both of them is the same thing but it can't. This can be a bug also.

     

    Sooo ......

    I desire from BOYUM IT to write my name on the bug finder list :)))

     

    Comment actions Permalink
  • Avatar
    Zendesk Bot
    Thank you for your request.
    The development team have now added it to our internal planning-system for evaluation.
    [Internal Id: 18733]
    Comment actions Permalink
  • Avatar
    Kasper Bergh Østergaard

    Could you please show a screenshot of your configuration?

    Comment actions Permalink
  • Avatar
    erol akgül

    Of course Mr Kasper,

    I changed all column names with those rules;

    ** max 10 characters

    ** not using the big i letter (I), like DSC OR DMETER instead of DISC or DIAMATER

    so, now code runs .

     

    MultiSetFromSql($[$38.U_DSMECH.0]|SQL:SELECT U_DISMECHANISM FROM OITM T0 WHERE T0.ItemCode = $[$38.1.0] );

     

    Comment actions Permalink

Please sign in to leave a comment.