SAP Bug: SAP 9.3 PL10 and PL11 Font-size issue makes screens too big running other font-sizes than Tahoma 10

Follow

Comments

6 comments

  • Avatar
    Rasmus Jensen (Edited )

    We now have a workaround version of B1UP ready that work around SAP's bug

    The version this workaround is in is called 2019.09 HF5 and can be downloaded here: https://www.boyum-it.com/sbo/Preview/

    I order to begin using the workaround you will need to activate it via a special file. Here is what you need to do:

    1. Install B1UP 2019.09 HF1 release

    2. On each machine that runs the B1 Client(s):

    2a. On your Window Desktop create a new text-file called "Fix93FontIssue"

    2b. Go to Folder: C:\Program Files (x86)\SAP\SAP Business One\AddOns\BOY\B1 Usability Package  (or C:\Program Files\SAP\SAP Business One\AddOns\BOY\B1 Usability Package if you run 64-bit)

    2c. Copy/Paste the file created in step 2a. into the above folder​

    3. Start SAP Business One and do an XML reset

     

    ***

     

    Still known issues after the workaround.

    There are a few things we can't find a workaround for. 

     

    1. Tabs are a bit ugly and a bit too far down (can't find a workaround for this :-( )​

    2. Matrixes rows are too high (Can't workaround this either :-( ) ​

    0
    Comment actions Permalink
  • Avatar
    Marcel Gerritsma

    Hello Rasmus,

    The fix worked for the normal SAP forms, but not for SQL report (Universal Function) forms. Is there a workaround for this as well?

    Regards,

    Marcel.

    0
    Comment actions Permalink
  • Avatar
    Rasmus Jensen

    Hmm, it also fixes it for my SQL reports. Did you remember to do an XML Reset? If so please try and post a screenshot of how it looks incorrectly for you?

    0
    Comment actions Permalink
  • Avatar
    Marcel Gerritsma

    Hello Rasmus,

    When I open the sqlreport window with fontsize 10, the buttons are visible, when I change the fontsize to 12, the buttons are still visible, but when I reopen the sqlreport window, the buttons are gone.

    Do you have any advise.

    Regards,

    Marcel.

    0
    Comment actions Permalink
  • Avatar
    Rasmus Jensen

    Function Buttons on a SQL Report normally only fit one font-size so guess this is not related.

    Try the following:
    - Remove the Buttons
    - Switch to Font-size 12
    - Open screen once
    - Add Function Buttons

    If still not working it might be a side effect of the Font-issue I've just not seen before (but in general PL10 and PL11 is very broken and should not be used or only be used on Font 10)

    0
    Comment actions Permalink
  • Avatar
    Marcel Gerritsma

    I now fixed the issue with ItemPlacement.

    Regards,

    Marcel.

    0
    Comment actions Permalink

Please sign in to leave a comment.