Skip to main content

CRM for Outlook will require .Net 4.7 or higher installed as of February 2019